欢迎

Password Safe

你有多少用户名和密码需要跟踪保存呢？无论答案是一个或数百个，Password Safe 都能让你轻松、安全地建立一个安全并加密的主密码清单，以及提供一个单独的主密码解除所有锁定的密码清单数据库（保险箱）。

安全始于用户！保留书面密码清单在便条纸或在桌面的文本文档上都是极为不安全的，并很容易被窥视（基于网络和人两者）。许多人使用相同密码一遍又一遍的在广泛的系统和网站用来用去，长此下去也许噩梦将不期而至。比如一旦有人算出一个密码，他们将能算出你的所有密码，并立刻有机会获得你生活中的每一部份（系统、电子邮件、零售、财务、工作）。

Password Safe 允许用户管理旧密码和轻松快捷的生成、存储、组织、检索及使用复杂的新密码；利用密码策略控制，一旦存储，每次仅需点击几下用户名和密码便可离开。

利用 Password Safe 用户能够使用自定义参考组织密码，例如：用户ID、类别、网站或位置。并可以选择存储所有密码在单独加密的主密码清单（高强度加密的密码数据库）中或使用多个数据库进一步组织密码(例如：工作和家庭)，相信它直观的界面和快速运行等便捷优点，能成为你装机必备的优秀软件。

Password Safe 的 windows 版本是一个完全免费与开源的多语言版软件。软件以 C++ 开发而成，其严谨简洁的语法，令本程序运行迅速、占用资源少，在众多密码管理软件群中，可谓出类拔萃。其利用 Twofish 算法为你加密的数据库，暂时无人能破解（包括程序开发者），所以请一定记得别忘了你的数据库主密码，不然没有任何人能帮助您找回已存的所有密码信息。本软件绝对不包含任何恶意插件、后门、更不包含木马病毒等代码，请您完全放心使用！


关于 Password Safe

Password Safe 使用Bruce Schneier 和 Counterpane 实验室原先制定和公布的 Twofish 加密算法。

Password Safe 目前是一个开源项目，托管在 sourceforge.net。最新的程序更新、文件和新闻位于 http://pwsafe.org。

Password Safe 可以免费获得，并根据开放源码倡议(OSI)中规定分配的限定标准制作了“典雅许可证 2.0”，该许可证副本包含在 Password Safe 安装程序包中，文件名称为英文 LICENSE。

Twofish 是一种快速，免费替代 AES、DES 和 IDEA 的加密算法。Twofish 算法的详细资料，包括速度比较和广泛的产品清单，使用 Twofish 等信息，可见于 http://www.schneier.com/twofish.html.

请从安装目录文件夹中阅读 readme.txt、changelog.txt 和 releasenotes.txt 文件的有关程序最新更改、bug 修复和文档附录等信息。

所有其它品牌或产品名称均为其各自公司所有，不支持或赞同这些公司存在或暗喻。


创建一个新密码

创建与打开一个保险箱

Password Safe 允许用户存储所有密码在一个单独的 “保险箱”(密码数据库)或创建多个不同用途的数据库(例如: 一个为工作，一个为个人使用)。每个数据库能被移动和用于不同的系统上，只要安装了相同版本的 Password Safe。 数据库加密使用一个源于主密码的密匙(主密码无论如何不以任何形式存放在数据库中)。

如果是首次使用 Password Safe，可以单击新建数据库按钮，接着将询问用户选择密码数据库名称和位置(默认 "pwsafe.psafe3" 不错)。 然后，提示输入一个用于加密的主密码和锁定新保险箱内容。

创建一个新数据库

有两个途径可以创建一个新数据库。一个是当程序启动时从密码保险箱项目对话框单击新建数据库；另一个是在已打开的 Password Safe 从文件 > 新建...菜单。不管利用何种方法只要能促使密码保险箱设置对话框呈现便可。

备注: 默认时 Password Safe 将显示最后使用过的数据库， 和为它显示一个保险箱提示。如果使用多个数据库，可以在它们之间的下拉列表交替选择。 也可以输入路径或从文件对话框通过单击省略号(“...”)按钮选择打开数据库。 数据库一旦被打开，便可以从文件菜单通过打开数据库命令更改打开其它数据库。

new safe combination prompt

虚拟键盘

要设置一个可靠的性的主密码，你可以使用字符（如：在使用德国键盘）像 ä, ö 一样或模拟。要实现如此字符的输入，你也许需要一个外国的键盘。这样的一个键盘就只能选择虚拟键盘了。该键盘一直以来被用于模拟所有可见的外国字符。虚拟键盘被显示为 Symbol virtual keyboard 标志。那些未见于物理键盘的外国字符，都将被显示在此。所以你可以创建你想要的主密码，但只有主密码可通过该方法创建。

Input a password with a virtual keyboard


使用已存储的密码

Password Safe 提供几种机制利用存储的用户名和密码。 大多需要复制用户名或密码到剪贴板，然后粘贴信息到所需输入的区域里。 Password Safe 提供一个自动输入功能，可以自动输入用户名和密码到一个网页表单里。

  1. 打开 Password Safe
  2. 选择希望使用的用户名/密码项目
    用户名:
  • 从工具栏选择用户名图标
    或
  • 右击和选择复制用户名到剪贴板
    或
  • 使用 Ctrl + U
    然后粘贴用户名到想要的区域里。
    密码:
  • 从工具栏选择密码图标
    或
  • 右击和选择复制密码到剪贴板
    或
  • 右击选定项目
    或
  • 使用 Ctrl + C
    然后粘贴密码到想要的区域里。
备注: 用户名和密码也可以通过选择设在编辑菜单被复制到剪贴板，但是坦率的说，点击它太远了点！


查找

查找一个特定文本

Password Safe 允许查找一个项目和某一个特定文本。如果不记得一个项目的名称时，这是非常有用的。 但必须要知道有效的相关内容，例如: 项目备注中具有“玛丽”的内容，查找时会自动定位到包含该内容的项目。

要查找一个打开的保险箱，按 Ctrl-F 键(或编辑->查找...)，在应用程序窗口底部于状态栏之上将显现和下图相同的一个工具条:

最简单的方法就是使用刚才输入的正在查找的文字方法，然后按回车键或单击文本框右侧的 locked 放大镜图标，相匹配的项目(如果存在)数量将显示在工具条右侧和第一匹配项目将被选中并着重突出。 按回车键（或单击放大镜）多次将移动到下一个匹配的项目。当所有项目被选中后，Password Safe 将返回到首行。

  • 要关闭工具条，单击文本框左侧的 locked 图标或再次按 Ctrl-F。
  • 默认时，查找不区分大小写。需要切换区分与不区分大小写，单击 locked 按钮， 当按钮字母变为 locked 时便区分大小写搜索。
  • 需要执行一个更高级查找，如限制查找一个项目的子集，限定只能查找哪些区域字段等等，此时请单击 locked 图标。
  • 需要清除已查找的文字，单击 locked 图标按钮。


升级早期版本的 Password Safe

为了支持新的功能和增强安全性，在主要版本之间用来存储项目的数据库格式和参数选择已经改变。然而，还有许多已经被努力改进的确保自动和显而易见的升级:
  • 1.x 版本的 Password Safe 只能读取1.x.生成的数据库。
  • 2.x 版本的 Password Safe 可以读取自身建立的数据库及1.x版本 Password Safe 生成的数据库。
  • 3.x 版本的 Password Safe 可以读取所有早期版本建立的数据库。
在所有情况下，读取一个由早期版本 Password Safe 生成的数据库， 只是打开它像所有数据库一样，项目将正常显示，可能 "未知" 字段值不被早期版本支持 (例如: 建立一个项目的日期)。
当保存这样一个数据库时，将被提醒新数据库不能被早期版本的 Password Safe 读取的事实。

生成早期版本的数据库

用户可以建立能通过旧版本 Password Safe 读取的数据库并明确输出为想要的格式(文件 > 输出和选择V1 旧版本格式...或V2 旧版本格式...)。 请注意输出的数据库将不包含附加在新版本中的信息。例如：一个版本 2 的数据库将没有涉及项目修改时间的信息。


关于主密码的话题

其中最重要的密匙，是为 Password Safe 数据库选择一个强有力的主密码保护您的密码（保险箱）安全。 在数据库（保险箱）中包含了你的所有用户名，密码，和可以添加的所有附加信息。记住最好不要选择这些密码，例如: 挑选配偶的姓名，生日，或其他一些容易推测的密码组合及您的敏感数据。重要的是，需要选择一个他人难以猜测但自己却能够轻松记住的主密码。

Password Safe 有一个内置的检查它认为薄弱主密码的功能。总而言之，一个主密码(无论你喜欢哪个密码) 应该由混合大小写字符和至少一个数字或特殊字符 （例如那些建立在键盘数字键上方的符号）。如果一个主密码输入程序被认为强度太弱，它将提示你确认。你可以选择接受刚输入的（弱强度）密码或重新输入新组合密码。

需要更改主密码，请查看更改主密码。

注意: 关于这点是没有办法在 Password Safe 里找回丢失或被遗忘的保险箱密码的！
这是一个有意设计的决定，因为使用任何机制来检索密码丢失造成的安全漏洞都可能被利用。


用户名和密码

用户名、密码和组:基本

用户名、密码和组连同附加参数被安排在四个选项卡:

  • 基本: 所有密码管理的必要元素。
  • 附加: 附加规则，包括历史密码。
  • 日期和时间: 密码失效日期与统计信息。
  • 密码策略: 指定有别于默认的密码策略。

基本 选项卡

该选项卡里组合了最重要的基本字段。

Edit/View Entry

下列缩进为与每个密码项目相关的信息:

  • 组: 为归类（组织）多个相关项目的名称
  • 标题: 为一个密码项目的友好名称
  • 用户名: 用户名称
  • 密码: 项目的密码
  • 备注: 自由形态的生成备注字段
  • 只有标题和密码字段是必需的；其余为可选项。
另外，下列字段可被设定在该选项卡:
  • 网址: 与项目关联的网址。如果该字段未空，则浏览按钮被启用。 如未规定协议，则“http://”被假定（例：“www.foo.net” 与 “http://www.foo.net” 相同）。 按住控制键的同时单击它（Ctrl+单击），将调用自动输入功能在被打开的浏览器页面输入相应的用户名和密码。查看下列备注了解更多信息
  • 电子邮箱: 与该项目关联的邮箱地址。 如该字段未空白，则发送按钮被启用。单击该按钮将调用默认的电子邮件程序并转到: 字段已指定的邮件地址。查看下列备注了解更多选项。
    下列备注描述有关网址句柄的更多细节:
  • 默认情况下，Password Safe 将调用你的电脑通常打开网页时所用的浏览器。如有必要，你可以指定一个其它的浏览器， 在替换浏览器网址字段前输入[alt]。例如: “[alt]http://www.foo.net”。该句柄有助于，例如: 如果你的默认浏览器为 Firefox 而你希望访问一个网站时最好使用 Internet Explorer。需要设定一个替换浏览器 单击管理->选项->杂类对话框。
  • 如果在网址之前放置“{alt}” 则它被“原样”传递给替换浏览器，虽然没有指定协议即未添加“http://” 这是默认状态。假如替换浏览器为一个远程访问的应用程序，例如：一个 SSH 客户机。[ssh] 将获得同样效果。
  • 如果网址之前已建立了“[autotype]”，则之后的网址被显示为可操作状态， Password Safe 将利用该项目自动输入字段执行自动输入动作，或假如未作规定时执行默认值。
电子邮件地址根据标准规则 (依照 RFC 2368):
  • 一个或更多的有效邮件地址可通过分号分隔，使用互联网安全字符及使用 %20 作为空格符号。
  • 地址可以通过下列一个或更多对的名称值。 首对应该加上一个前缀“?”以及所有其它的名称对之间增加一个(&)符号。 名称可以跟随字串:
    • subject - 跟随文本呈现于“subject”行的消息。
    • body - 跟随文本呈现于“body”的消息。
    • CC - 跟随地址被包含在“cc”(副本)章节的消息。
    • BCC - 跟随地址被包含在“bcc”(信件副本)章节的消息。
例: 用户@example.com?subject=消息 Title&body=消息 内容"

新建一个用户名称和密码项目

  1. 打开你想要新建项目的数据库
  2. 从编辑菜单中选择添加项目
  3. 输入必需的信息到编辑/查看项目对话框字段里
备注: 如果一个组名称被选定，然后再增加一个新项目，那么项目 的组名称将会预填充到编辑/查看项目对话框里。 如果一个新建组名称被添加到组字段，那么该组名称将被创建。

生成和编辑密码

如果你想要手工输入自己的密码到密码字段里，或通过Password Safe生成一个基于当前 密码策略类型的密码，需要Password Safe 生成一个密码，只需在编辑/查看项目对话框 单击生成按钮。 如果你不满意生成的结果，你可以再次单击生成按钮或手工编辑它。

备注:
  • 如果你利用“单点登录”系统，则允许你共享相同密码跨越不同的计算机/服务器/应用程序等。 你可以设置相应的Password Safe项目， 以便更改一个密码作用所有其它相关项目。这是一个称为“别名”的项目和详细解释，单击这里.

编辑现有项目

  1. 从列表选择密码项目编辑
  2. 从编辑菜单选择编辑/查看项目
备注: 默认状态时密码不可见。需要查看相关项目的密码，单击显示密码。

添加一个新组

  1. 从编辑菜单选择添加组
  2. 输入组名称

编辑组名称

这里有二个途径三个菜单可以获得修改组名称。

  1. 右击组并从弹出的下拉列表选择重命名组，在原组名称虚线框上直接修改
  2. 右击需改名组其下的项目，从弹出的下拉列表选择编辑/查看项目，在打开的编辑项目下基本选项卡对话框组字段键入名称
  3. 先鼠标左键单击单击需改名组下的项目，然后选择主菜单栏编辑->编辑项目在打开的编辑项目下基本选项卡对话框组字段修改组名称
备注: 组名称可被“嵌套”安置一个组名称在另一组名称之下（内）。编辑项目对话框组字段里，如果有多层结构的名称存在，分别使用符号“.”分隔。 如果需要把组编辑更改在数据库根目录上，则只能保留一个独立名称。要在根目录组下嵌入其它组名称，其后请使用“.”分隔。


用户名和密码

用户名、密码和组: 附加

用户名、密码和组连同附加参数被安排在四个选项卡:

  • 基本: 所有密码管理的必要元素。
  • 附加: 附加的规则，包括历史密码。
  • 日期和时间: 密码失效日期与统计信息。
  • 密码策略: 指定有别于默认的密码策略。

附加 选项卡

  • 自动输入: 如果该字段未空，它的内容将替换为自动输入函数的默认值。需要了解更多信息，请查看自动输入帮助主题。
  • 运行命令: 该字段可被用于指定一个命令或通过操作“运行命令”运行程序（通过编辑菜单，右击弹出菜单或快捷键 Ctrl-R）。 Password Safe 可以传递自变量到命令行，如：项目的用户名，密码等。 所述查看这里。
  • 双击项目: 该选项允许你定义当你双击一个 PasswordSafe 项目时将产生何种动作。 默认状态下，双击为复制项目密码到剪贴板。默认操作设定在管理->选项->杂项。
  • 历史密码: 该选项可以配置 Password Safe 保存项目的最后几个历史密码。这里可以在你创建一个项目或查看一个现有项目时完成其中的配置。 你可以查看项目最近相关的历史密码，也可以更改被保存的最近历史密码数量。欲了解更多信息，请查看历史密码页。


用户名和密码

用户名、密码和组: 日期和时间

用户名、密码和组连同附加参数被安排在四个选项卡:

  • 基本: 所有密码管理的必要元素。
  • 附加: 附加的规则，包括历史密码。
  • 日期和时间: 密码失效日期与统计信息。
  • 密码策略: 指定有别于默认的密码策略。

日期和时间 选项卡

Edit/View Dates and Times
  • 密码效期:要设定一个密码失效日期，单击“设定”按钮和指定 想要终止的日期，任何一个绝对日期（如：2010.12.31 00:00）或相对日期天（如：30天后）。 当分配的日期临近时， Password Safe 将在启动时通知你应该改变密码，同时也标记项目为截然不同的颜色。
    如果你选定“在 N 天后”, 还可以指定“重复”截止日期。这样导致一个新的截止日期作为基于 你改变项目密码与指定天数的计时。 例如：如果创建一个项目在一月一日和指定五天之后重复截止日期，你将在一月六日得到一个期满通知；如果 如果你在一月七日更改密码，则新的截止日期将在一月十二日（在密码设定 5 天之后）。
  • 要取消失效时间，单击“清除”按钮。
  • 统计信息: 这是只读字段，仅帮助了解被选中项目的创建时间、最后访问信息等。
备注: Password Safe 将 只有 当用户密码失效时发出警告，提醒用户负责更改密码。


用户名和密码

用户名、密码和组: 密码策略

用户名、密码和组连同附加参数被安排在四个选项卡:

  • 基本: 所有密码管理的必要元素。
  • 附加: 附加的规则，包括历史密码。
  • 日期和时间: 密码失效日期与统计信息。
  • 密码策略: 指定有别于默认的密码策略。

密码策略 选项卡

Edit/View Password Policy

如果你不想使用默认的密码策略（查看设置一个密码策略），你可以在该选项卡定义一个不同的密码策略，单击选中“使用下面的策略”选项和设置适合自己的其它元素。


设置一个密码策略

一个密码策略描述规则用于创建一个必需的密码字母，大小写字母、长度和任何特殊字符。 有些惯例只需要小写字符，而有些却要求大写字符、数字和使用特殊字符以及规定的最小长度。 使用密码允许最大长度和允许字符混合最大限度，总的来说这是一个好的建议。请根据它们的要求校验调整准确的密码。

密码策略对话允许用户设定全局密码生成策略，该策略可被临时忽略和在编辑/查看项目对话任何时间手工编辑密码。

选定密码规则

请为每个“使用”项目(例如: 使用数字，使用符号，等等。)在 Password Safe 对话框点击包括生成密码指定字符的复选框。 每个密码将被生成所指定的长度(不再缩短)。唯一例外的是仅使用十六进制数字复选框被勾选时，密码将只包括这些字符代表十六进制数字。选择该选项时，所有其它勾选框将被禁用。

选择生成可发音密码将促使 Password Safe 生成一个“无意义”但应该可以读音的英文字词，例如:“ingstria”，“ringsony等等。当用户需要一个密码具安全又相对容易记住和在没有 Password Safe 的情况时，这是非常有帮助的。选择该选项使用数字和/或使用符号将使一些字母替换成相等于“黑客语”特征的字符，例如:“E”可能替换成“3”、“S”替换成“5”等等。

当使用符号被选中时将附加这些字符: + - = _ @ # $ % ^ & ; : , . < > / ~ \ [ ] ( ) { } ? ! | 除非仅使用易解读字符也被选中，在这种情况下，只有字符: + - = _ @ # $ % ^ & < > / ~ \ ?

在仅使用易解读字符被选中时使用这些字母: a b c d e f g h i j k m n o p q r s t u v w x y z 和 A B C D E F G H J K L M N P Q R T U V W X Y 以及数字被限制为 3 4 6 7 8 9。


历史密码

Password Safe 允许用户根据所设定的日期保存最近一些用于某一项目的密码。 这是有益于显示符合以密码策略作为所需某些工作场所和如果为某些更改在没有奏效的情况下恢复一个早期密码。 访问一个项目的历史密码可通过单击编辑项目->附加选项卡对话框中的“历史密码” 按钮。
Password History

该对话框显示最近一些关联特定项目的早期密码。需要显示这些，在编辑/查看项目对话框单击“附加”按钮。用户可以根据下列操作 :

保存 N 个最后密码

如果用户选定该复选框，则该项目最近密码将被保存。也可以规定保存多少密码。
备注: 不选定该复选框将不清除历史密码，将只停止 Password Safe 为该项目存储更多密码。

复制一个密码

单击最近密码列表中的一行将复制密码显示器中的该行到剪贴板。

清除历史密码

单击该按钮将清除这个项目所存储的早期密码。
备注: 在编辑/查看项目对话框点击确定按钮之前不作出实际的修改。 如果错误的单击清除历史密码，在编辑/查看项目对话框中只能单击取消，而不能点击确定按钮。

全部复制

单击该按钮将复制项目历史密码列表(日期和密码)到剪贴板。


更改保险箱密码

更改主密码

Key Change dialog box

需要更改一个主密码 (“保险箱密码”)，首先打开想要更改密码的数据库。打开后转到管理菜单和选择 更改保险箱密码。输入当前主密码，然后输入新的主密码(两次，为了确认)。

Password Safe 存在一个它认为是薄弱主密码的检查设置。一般来说，一个主密码 (如任何密码) 应该包含混合大小写字符和至少一个数字或特殊字符(如键盘数字键上方的符号)。 如果所输入的主密码被程序认为是弱强度密码，将被提示确认。可以选择接受所输入(弱强度)密码或重新输入新组合密码。

备注:
  • 没有任何途径在 Password Safe 里找回丢失或被遗忘的保险箱密码。
    这是一个故意设计的决定，因为使用任何机制来检索丢失的密码所造成的安全漏洞都可能被利用。
  • 请选择一个让人难以猜测的密码。如果是一个很平凡的密码，例如:“密码”或你的名字是很容易被推测和否定了 Password Safe 提供的安全性。


自动输入

自动输入为用户提供一个简易快捷输入用户名与密码信息的途径。 单击需输入的用户名和密码及递送主机认可的数据。默认状态，公式跟随自动击键如下: 用户名，接着换行、密码、再换行、最后输入键(用户名 换行密码 换行输入)。 该操作能满足大部分网站所需要的用户名/密码验证。

为了网站或应用程序需要不同的数据，可以在自定义自动输入章节下设计描述自动输入特性。注意也可以通过选项对话框的杂项选项卡自定义默认自动输入文本。 这是很有帮助的，如自动输入能非常快速的输入到计算机中。

使用自动输入

  1. 把光标置于表单的用户名字段里
  2. 最大化或打开 Password Safe
  3. 选定一个密码项目
  4. Ctrl -T 或右击和选定执行自动输入或在工具栏按钮单击启动。

自定义自动输入

由于网站或应用程序存在需要用户名字段和密码字段来使用登录按钮登录，可以修改“自动输入”字段特征指定想要填写的文本，特征如下:

  • \u 代替用户名关联项目。
  • \p 代替密码关联项目。
  • \g 代替组关联项目。
  • \i 代替标题关联项目。
  • \o 代替备注 (可能多行文本) 关联字段。
    • 所有行字符“\n”、“\r”或“\r\n”结束均转换为“\r”(回车)。
    • 不代替生成转义序列在备注字段里 (例如: “\u”、“\p” 等。)除“\t”之外序列使用制表符取代。
  • \oNNN 是代替备注字段某行内容
    • NNN 可通过一至三个数字 (例如: \o5 为第五行 ，\o45 为第四十五行等等。)
    • 行尾字符不包括。
    • 如果 NNN 大于备注字段行数，则没有效果。
    备注: 这是一个最简便支持应用程序自动输入的方式，需要第二次密码或其它任意文本为认证过程部份。
  • \b 代替退格键。
  • \t代替换行键，空指令字段有效。
  • \n代替回车键，按回车按钮效果。
  • \\代替反斜杠 ( \ ) 键。
  • \dNNN 设置字符之间的延迟 NNN 毫秒， 而不用 10 (默认)。
    备注: 可以使用 \d 命令连贯一个数字。例如: \d999\d999\d999\d010 给予 3 秒延迟(3.007, 精确的)。 \d 命令设置字符间延迟和同时立即产生延迟。
  • 所有其它文本输入示列。

示例: 下列可用于银行帐号位置 (12345)，必须输入在用户和密码前:

12345\t\u\t\p\t\n

备注: 默认情况，自动输入字段不显示在添加或编辑对话框。 要访问自动输入字段，可以在对话框单击“更多>>”按钮。

如果自动输入存在问题，可能需要禁用第三方插件弹出拦截。即用户使用自动输入功能时弹出插件拦截报告问题的相互影响。


备份与恢复数据库

由于存储在密码数据库中的信息通常是敏感和重要的， Password Safe 为备份与恢复密码数据库提供了不同的机制。该章节描述了如何手工生成密码数据库备份。 Password Safe 同样可以配置在每次保存数据库时自动生成数据库备份。这样的备份被命名为中间备份并描述在这里。

生成备份

安全的创建一个当前密码数据库副本。

  1. 单击生成备份
  2. 为备份文件选择一个位置
  3. 单击保存

备注: 强烈建议经常生成密码数据库备份文件，这样将帮助保护密码列表防止系统事故或文件被破坏。 备份加密，使用相同的主密码作为当前数据库备份。

恢复备份

恢复一个备份的密码数据库文件。

  1. 单击恢复备份
  2. 定位备份文件的位置和选择文件进行恢复
  3. 单击打开
    将出现密码提示对话框。
  4. 输入数据库密码并单击确定
备注:
  • 恢复的数据库具有“保存的” Password Safe 标准数据库扩展名 (.psafe3)。在文件菜单选定保存或另存为， 如果退出程序之前没有对文件作出保存操作，程序将提示 "保存" 数据库和为它选定一个名称。
  • 在这里除备份与恢复描述之外，当保存一个更改之前 Password Safe 将自动的保存一个数据库副本， 副本使用除扩展名外其余与当前数据库相同的目录和名称(备份扩展名为 ".ibak" 代替保存的数据库 ".psafe3")。查看这里了解更多关于自动备份的信息。


备份选项卡

备份选项卡允许配置如何创建自动备份和管理。

编辑或添加后直接保存数据库

当勾选此项，Password Safe 将直接保存所有被更改的密码项目，不需等待用户使用保存或另存为及确认。

保存之前创建中间备份 (.ibak)

当勾选此项，Password Safe 将在每次保存之前复制数据库。备份副本的名称和位置及应该保存多少副本定义在下列字段。

备份名称

备份文件名称由 基于(默认状态，数据库名称没有 .psafe3 扩展名)一个后缀(无、一个运行计数或备份的日期/时间)的名称。 在这里可以配置命名备份文件及保存多少数量的备份文件。Password Safe 将自动删除超过所指定备份数量的旧数据库。注意，如果备份文件后缀为一个递增数量编号(运行计数) Password Safe 将只删除旧数据库。

备份目录

默认状态，Password Safe 将存储备份文件在当前打开的数据库相同目录下。 在该字段可以指定一个备用位置，例如: 指定一个目录，网络驱动器、U 盘等等。当然，必须要有指定目录的写入权限。


故障保护备份

当 PasswordSafe 正常退出时，系统会提示你是否未保存更改到数据库。但是，假如你注销 Windows 会话，关机或重启电脑， 则 PasswordSafe 可能没有机会提示你。

在这种情况下，PasswordSafe 将尝试做一个“故障保护备份”（文件扩展名'fbak'）。该备份文件将创建在和当前打开的数据库相同的目录中。 当前数据库和它的“规则”备份将不被影响。

当再次打开原始数据库时，PasswordSafe 将检查存在的任何故障保护备份文件，如果发现，将显示一个类似于下列的对话：

Failsafe Backup Display during Open

第一行是关于指定数据库遵循的一般信息（与显示在 文件->属性 对话相同）。其次是故障保护备份文件。 如果它们可以使用相同的密码打开当前的数据库，则它们的属性也将被显示；如果有不同的密码或不是一个有效的数据库， 则在密码栏显示一个“否”并且没有属性被显示。

可供你选择按钮如下:

  • 继续
    单击该按钮将促使 PasswordSafe 忽略故障保护备份文件并且继续使用当前选定的数据库。

  • 选择和继续
    选定的故障保护备份文件将被打开取代已选的数据库。

  • 删除
    该按钮将删除选定的故障保护备份文件。如果 Windows 在该媒体支持回收站（通常仅在本地磁盘）， 它将被移动到回收站；否则，将被永久删除。

  • 退出
    如果这是 PasswordSafe 启动时第一个被打开的数据库，PasswordSafe 将退出；如果不是，新打开的数据库将被取消； 如果存在现有打开的数据库，将继续保持打开。

  • 帮助
    显示该帮助主题

建议:

  • 如果你无法选择，可以继续使用当前数据库并使用数据库比较功能，从文件菜单显示当前数据库和故障保护备份文件之间的准确差异。
  • 如果你打开一个故障保护备份文件并决定它为你想要保留的版本，你应该保存它为一个正常的数据库。此时，考虑重命名至原文件名称， 或使用一个完整的新名称保存该故障保护备份文件。
  • 一旦你感到满意的恢复了正确的数据库，无论是原始数据库或故障保护备份文件，你都应该删除所有旧的故障保护备份文件， 因为这样你将不会被提示是否决定稍后恢复的提示。注：如果你使用该对话框来删除文件，且你的 Windows 版本支持媒体包含回收站， 被删除文件将被发送到那里，而非永久删除。

注意: 任何应用程序将信息保存在PC刚刚关掉，断电或处理器，硬盘或任何其他组件失败时，都将是灾难性的！ 正如所有的数据对你来说都很重要，所以你应该定期备份你的数据到其它媒体。 这些也可以是U盘驱动器，外置硬盘，网络驱动器，CD或DVD等。总之这些备份都应当存储在安全的地方。


导入项目

Password Safe 允许用户导入其它格式的密码信息。 这些文件可能通过其它应用程序所生成，输出成一个电子表格甚至利用记事本或类似的文字编辑器手工制作的文件。

Password Safe 支持格式为:

  • 文本文件
  • XML
  • 已存密码(其它密码管理实用程序生成的文件)

文本格式

文本文件用于导入包含一个或多个密码项目组成的密码项目文件。每个字段里的项目都是由一个字段分隔符分隔和每个项目可包含一个或多个行。 导入文本文件格式详细情况可在“纯文本输出与导入格式”章节中找到。

导入文本设置对话

可在处理文件之前配置导入到文本文件中的字段分隔符与导入到新项目里的默认组名称。

Import Text Settings

  1. 文件 > 导入...
  2. 选择纯文本文件...
  3. 为需要导入的文本文件设定导入设置与参数
  4. 如果一个备注字段已使用复式线分隔符，任何前一条输出或使用一个文本编辑器以便把它导入到这里，在导入处理时，备注字段将被复式线替换符号分成一个新行。
  5. 单击确定
  6. 选择文本文件导入。
  7. 在导入过程结尾，出现一个小对话框显示有多少额外项目及多少(如果有)分析不成功。
要点: 导入首行文件必须有一列标记分隔每项目包含的字段名称，例如: “组/标题、用户名、密码、网址”等。该行是通过“输出文本”函数自动生成，但必须手工添加给文件创建自其它工具。

XML

XML(可扩展置标语言)是一个流行格式作为传递应用程序来往数据的文件。Password Safe 可以导入 XML 文件， 它是按照图解定义生成在文件 pwsafe.xsd 中，以分配部份作为条件。


导出项目

Password Safe 支持已存储密码导出(和导入)到(从)若干格式文件。 需要删除数据使用文件 -> 导出菜单。支持格式为:

  • Password Safe v1 (适用版本为 1.x 的 Password Safe)
  • Password Safe v2 (适用版本为 2.x 的 Password Safe)
  • 纯文本文件
  • XML

导出适用于早期版本的 Password Safe 文件，只需选择想要的格式和指定希望创建的数据库文件名称。

导出文本

备注: 导出文本为所指定密码项目的一个无保护副本。在不充分使用后请删除该文件副本，使攻击程序难以获得及有效的绕过安全程序。
请最好不要使用该操作，除非你已了解和接受该风险！

Password Safe 允许导出密码项目为文本文件。该文件可能因此被使用或被其它程序修改。
将首先询问导入主密码或让确认可能导出数据库为一个未加密的文本文件。

Export Text

同样可以指定部份选项:

  • 密码项目将被导出字段之间存在标记的文件。例如: 在组、标题、用户名、密码和备注字段之间。“组/标题”考虑为单字段。 任何字段包含一个空白时将被导出在双引号字符里。 只有备注字段可以包含多行项目。正常处理每个备注行位置在导出文本字段里使用一个分隔行。 不过，这样使得它难以分类或使用比较两个不同导出文件时。要克服这个可以在导出它们时指定一个多行定界符分隔。 如果转到导入一个文本文件创建具有这样一个定界符，那么它必须被指定， 所有备注行将作为一个单独行出现在数据库结果里。
    如果必要，标记想要标记的所有分隔行于备注字段的一行上然后导入符号用作定界符。 由于备注字段整体被双引号标注，该符号禁止被选为多行定界符。

  • 更多控制导出格式可以通过单击“高级”按钮。将出现下列对话框:

Advanced Text Export Options

该对话框允许只导出基于文本指定字段项目的部份和/或指定哪些字段被导出。 在选定完成时单击确定或取消不作出任何更改返回到导出文本对话框。

此时将询问用户提供新文件名称以及如果文件已存在所指定的目录时确认覆盖同名文件。

备注: 详细的导出文本文件格式资料被建立在“纯文本文件导出与导入格式”节段。

XML

XML (可扩展置标语言)是一种流行格式作为应用程序之间传递数据。Password Safe 可以导出(和导入)数据库项目为这种格式。 构造(或规划) 以导出数据和验证定义为标准的文件pwsafe.xsd， 是提供作为布局的一部份。该文件被用于 Password Safe 在导入导出 XML 数据时。
备注: 导出文件为选定密码项目的一个无保护副本,请记得在不使用后及时删除它， 以防黑客入侵并有效绕过安全程序轻松获取其中敏感信息。该文件可以使用其它文本编辑器轻易打开，比如: Windows 记事本！
请最好不要使用该操作，除非你已了解和接受该风险！
显示的 XML 文件是使用 pwsafe.xsl(可扩展样式语言文件)表示的。 它是一个样品文件，可以根据你自己需要作出修改，提供作为一部份布局。 该文件只是一个样品和你可以轻易修改它显示你想要显示的任何字段。 虽然只作为显示数据和即使不修改它，但在稍后你将依旧可以导入它到 Password Safe 中。

作为文本导出选项，你可以控制项目和字段导出到 XML 文件，通过单击导出 XML 对话框上的高级按钮进入。该对话框将显示如下:
Advanced XML Export Options

该对话框允许你只导出部份项目， 基于指定字段的文本和/或指定哪些字段被导出。完成时单击确定或取消返回到导出 XML 对话框不作出任何更改。 请注意 XML 规划需要标题和密码字段，因此这些不能被取消选定。

你将接着被询问需要供给新文件名和如果文件已存在于你所指定的目录时需要确认覆盖同名文件。


筛选

“筛选”是任一项目匹配或不匹配的规则(或规则的设定)。PasswordSafe 允许用户定义筛选与只显示项目匹配的一个特定筛选。可以定义一个筛选作为一个以前的查询或定义多个筛选， 命名它们并持续储存它们作为重复使用。 也可以筛选任一存储的除数据库外或外部的数据，作为共享一样的筛选交叉多个数据库。

定义一个筛选

要定义一个新筛选，选择查看->筛选->新建/编辑筛选菜单项目。下列对话框将被显示:
Display Filter dialog box

为了便于查看，每个筛选由一个或多个行，在每个行位置定义一个 规则给一个特定的字段。 条件式定义每个行可选择“和”与“或”关联前一行。该项允许定义下列各种筛选:
1.所有项目包含一个用户名“joe”或“Joe”或“JOE”
example1
2.所有项目具有一个用户名“Joe”(精确的)创建在2008年5月1日之后
example2
3.使用项目包含一个用户名“Joe”或“Mary”
example3

为便于查看，筛选可任意组合。

下列是筛选表格栏目标识:
  • “#”- 该列为行编号。为了方便而显示及不能修改。
  • “?”- 勾选框在栏目中用以确定该行是否激活或禁用，只有激活的行被用于筛选。 单击勾选框启用/禁用行。
  • “+”- 单击这里插入一个新行在下面。
  • “-”- 单击这里删除当前行。注: 由于删除一个行是永久性的，可以只禁用而替代删除它。
  • “和/或”- 该项允许用户确定与前一行结果的关系。
  • “字段”- 选择想要的项目字段。例如: 用户名、标题、组、备注等。
  • “规则”- 定义用户所选中字段的值。一旦选中一个字段，单击时将弹出一个对话框允许用户指定规则，选择需要哪个被显示于表格。

应用一个筛选

一旦定义一个筛选，单击“应用”将筛选数据库中的项目，当离开时设定显示筛选对话框将被打开。 这有助于定位和提取基于筛选的结果。单击“确定”将同样应用筛选，但会直接关闭设定显示筛选对话框。

管理筛选

设定/编辑筛选对于筛选一个过去的任务是个好方法。 不管如何，假如用户查找的多个筛选需要重复使用，那么可以存储这些并供以后管理使用。使用该菜单可点击查看->筛选->管理...对话框操作。
Manage Filters

管理筛选对话框有两层表格。上层表格列出筛选方式，下层表格显示当前选中的筛选内容。
  • 需要添加一个新筛选，单击“新建”按钮。等同于选择 查看->筛选->新建/编辑筛选菜单项。
  • 需要编辑一个现有筛选，选择项目后单击“编辑”按钮。
  • 需要应用一个现有筛选，选中想要筛选行的勾选框，然后单击“应用”按钮。注意同一时间一次只能应用一个筛选项。

存储筛选

筛选可存储任一作为当前数据库中的部份或输出到外部作为 XML 文件。 存储筛选到外部是个好方法，因为可以跨数据库共享筛选，但存储它们作为数据库部份时，请确保潜在的敏感信息在筛选中是受保护的。
  • 需要存储筛选在一个外部文件里: 设定输出用户想要存储的外部筛选勾选框，然后单击输出按钮。
  • 需要存储筛选在当前数据库: 设定复制到数据库勾选框，然后单击复制按钮。
  • 需要加载一个外部存储的筛选: 单击输入按钮。
备注:
当启动时， PasswordSafe 搜索一个与 pwsafe.cfg 文件(默认状态在 PasswordSafe 安装目录位置)在相同目录下的文件名为 autoload_filters.xml 的文件。 如该文件存在，则它被自动导入并筛选它所包含准备使用的信息。 这是有助于假如用户有一个想要共享跨越多个数据库的筛选设定，很显然每次启动将导入它们。


命令行参数

调用 Password Safe 不带参数将导致应用程序提示为最后被打开过的数据库输入密码或在计算机未打开有过早期数据库时提示输入新数据库密码(例如: 首次使用 Password Safe)。 不管如何，尽可能修改 Password Safe 的这些参数引用如下:

  • pwsafe 数据库名称
    该参数将打开指定的数据库文件，而不打开最后一次被打开过的数据库。 假如只考虑一个文件名而没有路径，它将搜索其中被引用的应用程序目录。 注意，如果文件名和/或为空，将被双引号标识。
  • pwsafe -r [数据库名称]
    该参数将以只读模式打开指定的数据库。如果未指定数据库，则应用程序将提示用户指定一个需要被打开为只读模式的数据库。
  • pwsafe -v 数据库名称
    该参数将验证数据库在输入正确的密码语句后，校正内部不一致的错误。 对于通过其它应用程序写入数据库时这是有帮助的。
  • pwsafe -e 文件名
    该参数将提示用户给予一个密码语句和使用一个密码语句密匙加密文件。 注意: 文件可以是任何文件。被加密的文件将与原始文件同样的名称 ，是具有附加后缀为 ".PSF" 的文件。
  • pwsafe -d 文件名
    该参数将提示用户给予一个密码语句和使用一个密码语句密码解密文件。 注意: 该参数将只作用于被加密的文件已引用了 pwsafe '-e' 选项时(查看前一个参数)。
  • pwsafe -c
    该参数将启动应用程序的关闭菜单功能，即程序启动后没有数据库和没有初始打开对话(要访问数据库，使用文件菜单)。
  • pwsafe -s
    该参数将应用程序启动为“静默”，即最小化和没有数据库。 当解除应用程序最小化时，用户可见打开对话框(该选项表示启动应用程序时为登录界面，通过一个快捷方式启动用户文件夹)。 注意: 该参数调用设置应用程序在系统托盘。
  • pwsafe -m
    该参数与 '-c' 选项等同，具有增添应用程序启动时为最小化。
另外，下列选项承认:
  • -u 用户名
    该参数将导致应用程序读取和写入在指定 用户名 下的参数选择，代替登录名称。
  • -h 主机名称
    该参数将导致应用程序读取和写入在指定主机名称下的参数选择，代替本计算机名称。
  • -g 配置_文件
    该参数将导致指定用于加载和保存参数选择的文件，代替默认的 pwsafe.cfg。如果只给予一个文件名称而没有一个路径， 程序将搜索调用应用程序目录。注意如果文件名称 和/或 路径为空，将被双引号标识。
这些参数可能有助于假设你希望共享相同参数选择跨越多个计算机时，例如: 当运行 Password Safe 于 U 盘时。


文件菜单

文件菜单包含涉及管理与创建新 Password Safe 数据库选项。

新建

新建一个空白 password safe 数据库。

打开

打开一个现有 password safe 数据库。

关闭

在不退出应用程序的情况下只关闭当前已打开的 password safe 数据库。

最近保险箱

该文件菜单部份可列出最近打开过的数据库文件。如果是首次使用 Password Safe 该部份将为空白。

备注:

  • 最近打开文件列表可通过选择“清除最近保险箱列表”清除。
  • 最近 Password Safe 文件保存数量可通过管理->选项->系统对话框配置，如果你偏好在文件菜单查看最近文件或作为一个子菜单，也同样可以在这里配置。

保存

保存所有更改到当前保险箱。如不保存前面所作的更改或数据库被打开为只读，那么所作改动将被丢弃。

另存为

保存当前保险箱的一个副本在一个新名称或位置下。

导出

导出当前数据库内容为一个外部文件任一旧 Password Safe 数据库格式 XML 或文本文件。查看这里获得更多有关导出数据库为其它格式的信息。

导入

导入一个以前导出的内容或正确格式化的文本文件、XML 或一个公共应用程序保存的密码数据库到当前数据库里。 查看这里获得更多有关导入文本文件的信息。

合并

合并一个 Password Safe 数据库或备份文件(.bak)到当前数据库里。只读模式禁止合并。

比较

比较当前打开的数据库与其它数据库。

备注: 合并与比较操作两者都可能耗费较长时间，尤其是大数据库。

同步

使用其它数据库同步当前已打开数据库。 该合并数据库全部元素将被同步到当前打开的数据库。不管怎样同步期间，只有当前被打开的数据库元素被更新。

属性

显示当前被打开的 password safe 数据库有关信息。例如: 版本格式、组数量、项目数量以及最后保存时间并且由谁所作的保存等相关信息。

退出

关闭 Password Safe 程序。如果对数据库所作的改动一直未给予保存，关闭时将被提示保存数据库。


编辑菜单

项目 | 组
Menu Edit Entry | Menu Edit Group

通过编辑菜单可以添加、编辑、使用与组织用户名称及密码。 注意该菜单内容更改根据查看所选(例如: 选定项目或一个组)。并且，某些项目可以被禁用，描述如下。

添加项目

添加一个新用户名和密码。如果选择打开数据库为只读模式该项将被禁用。
查看用户名、密码与组获得更多信息。

编辑项目/展开/收缩组

当一个项目被选中时，编辑选中用户名与密码。 当一个组被选中时(在树状目录视图)，将展开或收缩项目显示在选中组之下。如果选择打开数据库为只读模式该项将被禁用。
查看用户名、密码与组获得更多信息。

删除项目/删除组

当一个项目被选中，该菜单将删除它。在选中一个组时 (在树状目录视图)，将删除所有选中组之下的项目。如果选中的组多于一个项目时则要求确认。如果选择打开数据库为只读模式该项将被禁用。

重命名项目/重命名组

重命名选中项目(或组，在树状目录视图)。如果选择打开数据库为只读模式该项将被禁用。

查找项目

查找一个包含特定文字的项目。默认状态，可查找除密码字段外的所有字段。
查看查找获得更多信息。

复制项目

复制选中项目。如果选择打开数据库为只读模式该项将被禁用。

添加组

创建一个新密码组(例如: 银行密码)。如果选择打开数据库为只读模式该项将被禁用。

清空剪贴板

清除剪贴板内存中记忆的所有内容。该项将清空剪贴板中被粘贴的任何 Password Safe 信息(密码、用户名、备注内容等)。 如果当前剪贴板没有包含来自 Password Safe 的内容，则该项操作不生效。

复制密码到剪贴板

复制当前选定的密码到剪贴板。

显示密码子集

该操作显示一个窗口允许指定哪些密码的字符被显示。这有助于站点要求登录密码组件时。 例如，一个密码可能为 "qAdm3ddENc" 和可能被询问输入第一、第三、第五和第八个字母。 该窗口允许制定一个合适方式: 在上面区域输入密码字符给密码子集。可以使用空格、逗号或分号分隔位置。 相应密码字符被显示在下面的区域中。需要退出，请使用 Esc 键。

复制用户名到剪贴板

复制当前选定的用户名到剪贴板。

复制备注到剪贴板

复制当前选定的备注字段内容到剪贴板。

复制网址到剪贴板

复制当前选定的网址字段到剪贴板。

复制邮箱到剪贴板

复制当前选中的邮箱字段到剪贴板。

复制运行命令到剪贴板

复制当前选中的运行命令字段到剪贴板。

浏览网址

当选中一个项目，并且该项目具有相应网址关联，则该项将调用默认浏览器浏览此网址。 如果未选中项目或选中的项目网址为空白，该命令将被屏蔽。

浏览网址 + 自动输入

当一个项目被选中和该项目存在其相关的网址时，则该项目将调用默认浏览的网址。 如果未选择项目或所选项目网址为空，该命令将被禁用。

自动输入用户名和密码到所选的输入字段里。
查看 使用自动输入 获取更多信息。

发送邮件

准备发送当前选定的电子邮件字段中的邮件数据。
查看 用户名称、密码和组 获取更多信息。

执行自动输入

自动输入用户名与密码输入到选定的区域里。
查看 使用自动输入 获得更多信息。

运行命令

该操作将执行所选项目字段 运行命令 中的命令。
查看 使用运行命令 获取更多信息。

创建快捷方式

当一个项目被选中，该项允许创建一个引用给项目代表其它组。这有助于假如有一个项目 “应被放在”超出一个组之下，但恰好又不希望复制数据时。一个快捷方式具有一个截然不同的图标 shortcut 相关联与存在默认名称 “快捷方式到 x”， 在 x 位置为原项目标题。当然，你可以编辑名称与移动或删除快捷方式，只要是符号规定的项目。

转到基本项目

该项将只显现在一个快捷方式或别名项目。 在单击转到基本项目之后对应的基本项目将被选中。

鼠标右击操作

许多功能通过在相应项目或组上右击鼠标按钮，在弹出的编辑菜单上同样可以实现。

项目 | 别名 | 组
Right click Edit Entry | Right click Edit Alias | Right click Edit Group

所有功能描述在 前一节段。


查看菜单

查看菜单控制器可用于显示选项。用户可以在项目的用户名与密码组织之间来回切换: 任何一个项目可作为一个单独列表(收缩列表)或类别组织(树状目录)。 可以选择是否显示工具栏或不显示，以及使用经典工具栏图标还是新式工具栏图标， 工具栏是可以自定义的。也可以在树状目录视图展开或收缩全部的组， 筛选显示器匹配任何规则，选择哪种字体显示项目，如: 合并报告、比较报告、输入与其它高级操作等。

在树状目录与展开列表之间切换查看

  1. 转到查看菜单
  2. 选择树状目录或收缩列表

控制工具栏

需要显示或隐藏工具栏，勾选或不勾选显示工具栏菜单项。
需要使用“新式”或“经典”工具栏图标，选择“新式工具栏”或“经典工具栏”各自的菜单项。

“拖曳栏”是一个特殊工具栏 ，允许粘贴当前选中项目的部份，通过“拖曳”指定图标局部，把它粘贴到用户想要的窗口中。 例如: 使用拖曳栏拖曳一个项目的“备注”文本到其它应用程序中。使用时先选定一个项目， 然后点击并按住鼠标左键从拖曳栏拖曳“N”图标到其它应用程序。 当用户释放鼠标左键时，备注字段内容将被粘贴到应用程序文本输入光标位置。 使用过程注释: 当点击并拖曳相应图标时，不一定非得一直拖曳至目标位置才释放鼠标左键， 可以随便拖离一下工具栏便可达到复制效果，然后再从鼠标右键菜单粘贴或按键盘“Ctrl-V”键粘贴复制的内容。 在拖曳时鼠标指针虽然变为不可用状态，但不影响其复制功能。当一个项目特定的字段空白时，相对的拖曳栏图标将不可用(显示灰色)。

拖曳栏图标说明:

经典 | 新式 | 描述
 |  | 拖曳该图标粘贴“组”字段到其它窗口。
 |  | 拖曳该图标粘贴“标题”字段到其它窗口。
 |  | 拖曳该图标粘贴“用户名”字段到其它窗口。
 |  | 拖曳该图标粘贴“密码”字段到其它窗口。
 |  | 拖曳该图标粘贴“备注”字段到其它窗口。
 |  | 拖曳该图标粘贴“网址”字段到其它窗口。
 |  | 拖曳该图标粘贴“电子邮箱”字段到其它窗口。

备注：需要显示或隐藏拖曳栏，勾选或不勾选显示拖曳栏菜单项。

显示查找工具栏

请参考查找一个特定文本章节。

全部展开

展开所有的组，使所有项目可见(仅树状目录视图)。

全部收缩

收缩全部组(仅树状目录视图)。

筛选

“筛选”是任何一个项目匹配或不匹配的规则(或规则的设定)。PasswordSafe 允许用户 定义筛选并只显示那些项目匹配的特定筛选。要获得更多定义与使用筛选的信息，查看这里。

更改字体

为显示在列表或树状目录视图的项目以及添加和编辑项目对话框中的密码显示选择一个不同字体。

报告

查看合并、比较、输入与验证操作的结果。


管理菜单

管理菜单是 Password Safe 的全部选项和控制设置。

更改保险箱密码

选择该选项弹出更改保险箱密码对话。
查看更改主密码的更多信息。

生成备份

创建当前密码数据库的一个备份副本。
查看备份与恢复数据库的更多信息。

恢复备份

恢复一个备份的密码数据库文件。
查看备份与恢复数据库的更多信息。

选项...

选择选项...弹出一个 Password Safe 具有多个设置可查看与编辑的选项卡对话框。要了解更多关于具体选项卡选择如下:

备份选项卡
显示选项卡
杂项选项卡
密码策略选项卡
历史密码选项卡
安全选项卡
系统选项卡
快捷方式选项卡
备注:
设置保存更多参数选择描述单击这里。

自定义工具栏

选定哪些图标需要显示于工具栏中和哪些则需要被隐藏。

生成密码

该菜单允许你依照密码策略，单击“生成”按钮生成的一组密码，并自动输入到剪贴板里。剪贴板中的密码可以在其后粘贴至其它某些应用程序中。


帮助菜单

帮助菜单提供访问各种资源和关于 Password Safe 的信息。

获取帮助 (F1)

打开该帮助文件。

访问 Password Safe 网站...

在浏览器打开 Password Safe 首页。

关于 Password Safe

该选项启动一个对话框显示版本号和版权标志，以及让用户检查是否有较新版本的 Password Safe 可用。请注意为了安全 Password Safe 将在连接到互联网检查新版本之前关闭用户数据库。

Password Safe About dialog box


工具栏菜单

这里有两种不同的工具栏图标视图可用: 新式工具栏和经典工具栏。 每个图标功能在工具栏上均提供弹出提示，只需将鼠标指针停留在图标上便可见小提示。 为了方便起见，该章节为每个图标提供了一个快速参考。

注意(从 3.11 版本开始)用户可以自定义哪个图标出现在工具栏并定制它们中的哪个被显示。

切换菜单图标视图

  1. 转到查看菜单
  2. 选择经典工具栏或新式工具栏

图标列表

经典 | 新式 | 默认 | 描述
 |  | X | 创建一个新保险箱并输入密码。
 |  | X | 开启一个对话并打开和切换到其它保险箱。
 |  | X | 关闭当前保险箱。
 |  | X | 保存所有更改到当前保险箱。
 |  |  | 保存所有更改到其它保险箱。
 |  | X | 复制选中项目密码到剪贴板。
 |  | X | 复制选中项目用户名到剪贴板。
 |  | X | 复制选中项目备注到剪贴板。
 |  | X | 擦除剪贴板记录。
 |  | X | 为选中项目执行自动输入。
 |  | X | 浏览项目记录的网址。
 |  |  | 浏览项目记录的网址，并执行自动输入。
 |  | X | 添加一个新用户 ID 和密码项目到打开的保险箱。
 |  | X | 打开当前选中的密码项目进行编辑。
 |  | X | 删除当前选中的保险箱项目。
 |  |  | 切换为列表或树状目录视图。
 |  | X | 收缩全部打开的组(树状目录视图)。
 |  | X | 展开全部组(树状目录视图)。
 |  |  | 比较当前保险箱与其它保险箱信息。
 |  |  | 合并当前保险箱与其它保险箱内容。
 |  |  | 输出数据为一个文本文件。
 |  |  | 输出数据为一个 XML 文件。
 |  |  | 输入一个文本文件数据。
 |  |  | 输入一个 XML 数据文件。
 |  |  | 查看输入与合并操作报告。
 |  | X | 配置选项。
 |  | X | 打开帮助文件。
 |  |  | 运行命令。
 |  |  | 设置密码部分。
 |  |  | 管理筛选。
 |  |  | 编辑筛选。
 |  |  | 清除与设置筛选。
 |  |  | 显示查找工具栏。
 |  |  | 发送邮件。
 |  |  | 同步当前保险箱与其它保险箱。
 |  |  | 撤销最后操作。
 |  |  | 重复最后未完成操作。


显示选项卡

显示选项卡功能将控制 Password Safe 与密码项目如何显示。

总是保持 Password Safe 窗口在最前

如勾选该项，最大化时的 Password Safe 将总是保持窗口在监视器最前端，不管其它窗口的焦点。

列表与树状目录视图时显示密码/用户名

如勾选该项，在树状目录 视图展开时，项目关联的用户名密码将被显示在栏目中。用户名被标识在方括号中，密码则被花括号标识。收缩列表窗口则不可见。

在树状目录与列表视图工具提示备注内容

勾选此项，在目录树与列表视图状态下，当鼠标指向包含备注内容的项目上时，将自动弹出显示当前备注内容的提示。

添加与编辑时显示密码

如勾选该项，密码总是被隐藏在添加项目与编辑/查看项目对话，默认状态为可见。 在对话框单击“显示/隐藏”按钮，可以为指定的项目显示或隐藏密码。

编辑时显示备注内容

如勾选该项，备注内容将被默认显示在编辑对话；如不勾选，为了查看文本将需要单击备注区域。

添加与编辑备注时自动换行

勾选此项，将自动在备注字段插入换行符。

列表视图显示网格线

如勾选该项，突出网格线将被显示在显示列表，使它看起来很像电子表格。

在树状目录首位放置组

默认状态，项目被绝对按字母顺序排序在树状目录视图。当该选项被选中时，所有组将被显示在首行(按字母顺序排序)，接着为所有最高级别的项目。

突出显示已更改的项目

勾选此项，被修改项目文字将显示为其它颜色。

提前 N 天通知密码失效

如勾选该项，PasswordSafe 将在读取一个数据库时扫描所有项目 (在典型启动时) 并显示一列从当前日期开始至失效日期是 N 天或更少。

初始树状目录视图

该项确定当打开数据库时，项目将如何显示在树状目录视图。

初始系统托盘图标

该选项允许更改当 Password Safe 开始启动和在还未打开数据库时系统托盘图标显示的颜色。


杂项选项卡

一些程序默认混杂的选项显示在杂项选项卡。

确认项目删除

当勾选时，每次尝试删除一个密码项目均显示要求用户确认的提示对话。

档案最后访问时间

当勾选时，Password Safe 将记录每个项目被访问的时间 (例如: 当密码被复制或项目的详细资料被查看时等等)。 被存储的项目时间信息可通过项目对话框查看。
备注:
  • 当启用该选项时，即使在没有编辑项目时数据库也将被修改。 该方法在退出程序时可能提示用户保存数据库，即使没有更改任何数据。
  • 当数据库被打开为只读模式时，访问时间不更新。

Esc 键关闭本程序

勾选该项，Esc 可被用于关闭 Password Safe 在最大化时。注意如果系统托盘被启用(通过放置图标在系统托盘选项)，则 Esc 只关闭主窗口，通过双击系统托盘图标可被重新打开。

热键

当勾选时，用户可以选择自己想要的某个键作为 PasswordSafe 最小化在系统托盘时的快速恢复热键， 按键后将依次出现在右侧显示框里。该功能极有助于当窗口被其它应用程序掩盖时的快速恢复。 当选中此项时用户可以依次更改此热键，然后单击确定按钮保存它。

双击项目

该项允许用户定义当双击一个项目时 PasswordSafe 将作出何种动作。 初始默认状态为复制项目密码到剪贴板。可用操作如下:

  • 查看/编辑选中项目
  • 发送邮件
  • 复制备注到剪贴板
  • 复制密码到剪贴板
  • 复制密码到剪贴板后立即最小化
  • 复制用户名到剪贴板
  • 浏览网址
  • 浏览网址+自动输入
  • 运行命令
  • 自动输入

注意“复制密码到剪贴板后立即最小化”选项，不能与“最小化时清空剪贴板”选项同时存在；确实需要复制后最小化功能，必须先把安全选项卡中选中的“最小化时清空剪贴板”勾选框去掉才起效。

自动输入

  • 自动输入后最小化 默认状态时，Password Safe 在自动输入时将被最小化。如清除勾选框，Password Safe 将移动所有显示窗口“在后面”取代。
  • 默认自动输入字串 在这里用户可以指定自动输入字串默认给所有项目。注意可以忽略每个基础项目上的这些。 该选项有助于，例如: 用户希望为所有项目更改延迟。查看这里获得更多自动输入详细信息。

默认用户名

该选项允许用户设定用于每次新建一个密码项目时自动生成的一个默认用户名。 当选中时，名称输入将被插入到新项目用户名字段里作为默认。当然，如果需要用户可以编辑它。

替换浏览器

用户所指定在这里的浏览器，将被用于为一个选定项目使用“浏览”操作。当项目存在网址时可在之前放置“[alt]”，如: “[alt]http://www.foo.net”。这是有帮助的，例如: 假设用户的默认浏览器是 Firefox，并且希望访问一个网站使用 Internet Explorer，在这种情况下应该指定 Internet Explorer 作为用户的替换浏览器 (典型位置: “C:\Program Files\Internet Explorer\iexplorer.exe“)。
通过浏览器命令行参数字段，用户可以指定命令行选项给浏览器。


设置一个密码策略

管理历史密码

password history

当用户更改一个项目密码时， Password Safe 可记录项目早期关联密码。该选项有助于，例如: 在关联该项目位置更改未能奏效。 该选项还可指定是否为新项目默认保存最近密码，用户可以在添加项目或编辑/查看项目对话框选择总是忽略。

保存 N 个早期每项目密码

选择该选项框和设置相应值定义为新项目默认保留密码。

管理当前项目的历史密码

该部份允许用户修改现有项目的历史密码跟踪如下:
  • 停止保存早期密码 - 该项等同于清除在所有数据库项目中的 “保存 N 最后密码”选项框。注意该项将不会丢失已保存的历史密码，只是不再跟踪密码更改，直到重新激活保存历史密码为止。
  • 开始保存早期密码 - 该项等同与开启在所有数据库项目中的 “保存 N 最后密码”选项框。不具有历史密码的项目将开始保存其上所设的密码数量。 项目的历史密码将跟踪改动，但项目跟踪数量不改变。
  • 设定最大保存密码数量至上面的值 - 所有项目将开始保存至上面的密码数量。 不管怎样，如一个项目超过该项目保存的数量将丢失其历史密码。


安全选项卡

安全选项卡提供用户访问控制安全设置。其易用性和程序安全受这里列出的选项影响，但根本上不参与加密密码数据库。

最小化时清空剪贴板

勾选此项，当应用程序最小化时程序将清空剪贴板中的所有存储数据内容 (如密码)。 这是预防其他任何人或任何其它程序从剪贴板中读取内容。注意选择该选项对于在杂项选项卡中双击操作“复制密码到剪贴板并最小化”选项将导致意外结果(双击项目时密码虽然被复制，但最小化时却又被立即清空掉)。

退出程序时清空剪贴板

勾选此项，当界面被最小化或关闭时程序将清空剪贴板中的所有存储数据内容。这是预防其他任何人或任何其它程序从剪贴板中读取内容。

确认项目复制到剪贴板

勾选此项时，显示一个提示对话框要求用户每次从数据库复制密码到剪贴板时进行确认。

最小化时锁定密码数据库

勾选此项，当程序最小化时自动锁定密码数据库，而当再次最大化访问程序时必需输入密码。

锁定密码数据库在工作站界面

勾选此项将导致密码数据库空闲在规定的时间后被锁定在工作站界面。目的是预防未经用户授权访问时访问工作站。

密码数据库空闲超时后自动锁定...

勾选此选项和设置一个时间将导致 Password Safe 在所设定间隔时间过后还没有用户操作应用程序时自动锁定密码数据库。


系统选项卡

系统选项卡提供访问设置 Password Safe 涉及系统在运行时的相互作用。

在系统托盘放置图标

如勾选， Password Safe 将最小化至系统托盘区域；如不勾选，程序将最小化至任务栏。

系统托盘图标将指示密码数据库是否被锁定。锁定为 （ locked ） ；未锁定为（ unlocked ）如数据库被锁定，当用户从最小化恢复时将被提示输入主密码。 附右击托盘图标弹出菜单截图：右击锁定时 locked ； 右击未锁定时 unlocked 。

记住最后 N 个在系统托盘菜单使用过的项目

如放置图标在系统托盘选项被启用，可以在没有经过程序主窗口时，在系统托盘图标右击直接转到大部分最近用过的项目。 该选项允许用户配置多少最近使用过的项目保存在系统托盘图标列表中。

启动系统时自动运行 Password Safe

如勾选该项，当启动系统时将导致 Password Safe 自动启动在系统托盘。 注意，在首次双击系统托盘图标时程序将提示输入保险箱密码。

最近 Passwordsafe 数据库

该控制命令允许用户配置在文件菜单显示多少最近打开过的数据库。 注意需要退出和重启 Password Safe 以使改变生效。

最近数据库在文件菜单上作为子菜单使用

该选项确定如何让最近数据库呈现在文件菜单上 - 直接在菜单上或作为一个子菜单。

默认打开数据库为只读

设置该选项将导致 Password Safe 打开数据库为默认只读模式。 该选项也许有助于多用户环境，设为默认后的 Password Safe 允许由谁为第一人称写访问打开数据库与限制其它人在只读模式。使用该选项，用户可以通过位置策略限定谁可以写访问一个特定的数据库。

从注册表删除 Password Safe 数据

在 3.05 版本之前 Password Safe 用过注册表存储配置数据，例如: 非默认选项设置、最后打开的数据库等等。 从这个版本开始，该信息被分成数据库-特定的用户/计算机 特定的设置，后者存储在一个单独的配置文件中。 选择该选项和单击应用按钮将导致注册表设置被清除。这是有助于比如希望删除 Password Safe 在用户的 PC 上的遗迹。注意，不管如何， 该方法在旧版本的 Password Safe 上将恢复默认值给部份设置。
备注:
  • 如果早期版本的 Password Safe 从未被安装或假如数据已被删除，则勾选框和应用 按钮不被显示。
  • 在极少情况下，Password Safe 位置不能创建或写入配置文件时，注册表将被使用。


快捷方式选项卡

该快捷方式选项卡允许你修改默认快捷方式（同样为已知加速键）作为定义 Password Safe 各种不同的操作。 要更改一个快捷键（或添加一个新的），选择你希望更改的行，然后单击快捷键字段的条目。 所有你选择的组合键将作为定义该操作的快捷方式。例如：要获取文件属性对话框控制它出现时，按住Ctrl键和Alt键以及 P键，选择文件>>属性行状态时。 步骤是：单击快捷键字段，然后按住控制键Ctrl的同时，再按住Alt以及P键。 此时，在快捷键字段将出现Ctrl+Alt+P文字，并且一旦你按“确定”按钮，更改将立即生效。 更多有关可以（或不可以）被定义的快捷详细信息，请查看快捷键/加速键章节。

请注意你可以定义当前没有快捷键的地方，也可以使用你的选择替换现有默认的快捷方式。 你所选择的快捷方式将被存储在首选文件中，并且将在下次 Password Safe 启动时生效。

如果你决定需要删除一个快捷方式或恢复为特定的默认快捷方式，只需选中你想删除的快捷键字段行，然后右击，在弹出菜单上选择。 要恢复全部快捷方式为默认值，单击“全部重置”按钮。


别名

别名密码

如果你使用的是一个“单点登录”的系统，则允许你共享一样的密码跨越不同的计算机/服务器/应用程序等等。 可以设置 Password Safe 相应的项目，因此，改变一个密码会影响所有其他相关的项目，这个便是被称为“别名”使用的项目。本节说明如何定义和使用别名。

概要

基本概念是允许一个项目的密码引用到另一个项目。 该“引用”项目被命名为基本和 “指向”项目(或多项目)被称为别名。 当一个项目设定到另一个别名项目，该别名密码实际上“跟随”项目的密码: 如果复制别名密码到剪贴板，得到的复制密码其实是基本项目的密码。 如果更改了基本密码，则立即反映到所有与基本项目关联的别名项目上。 虽然这些听起来有点复杂，但实际用起来其实很简单和很直观的。 最难的部份是设置别名，如下所述。

定义一个别名

在 Password Safe，一个项目可以参考另一项目的密码，通过一个特殊格式的密码访问项目。 格式为引用项目的“名称”使用方括号标识。 大多情况下，可以看作“名称”为一个项目标题字段的同义词，因此，如果基本项目标题是 “基本”，例如，输入“[主要]”(无引号)在另一项目密码字段足以定义另一项目为别名的“基本”。

在一般情况下，“名称”可以包含所有下列字段，使用冒号分隔: 组、标题和用户名。注意如果标题在数据库中是唯一的， 则其它字段为可选。同样，如果组和标题一致或标题与用户同时指定一个唯一项目， 则对应用户或组不必指定。

在 Password Safe 项目中，只有标题字段是强制性的。组和用户名字段为可选，只要“组/标题/用户 名称” 的组合结果是唯一的便可。如上表明，别名“密码”处于 [g:t:u] 而实际上你只有指定足够识别的唯一信息给基本项目。 因此，如果只有一个项目的数据库具有标题“t”，则 [t] 就足够了 - 因为标题时强制性的和只有一个项目的情况，这是假定的标题。 如果有一个以上的项目具有此标题，将被警告和应该需要更具体鉴别基本项目，通过添加它的任一个组或用户名或两者！ 只要有一个唯一的项目信息可提供，下列任何一种格式都可被接受: [g:t:u]、[g:t]、[t:u] 或 [t]。 指定一个冒号在没有一个值的空白字段，例如: [g:t:] 说明项目具有标题“t”与组“g”和不具有用户名的值以及 [:t:] 说明项目具有标题“t”在根目录无用户名的值等等。

下面的例子说明了这一点。

例子

1. 如果基本项目的标题是“LDAP 服务器”和没有另外的项目使用该标题， 则通过定义一个项目 "[LDAP 服务器]" 为别名在密码字段。

2. 如果有“LDAP 服务器”项目在两个不同的组，说明 “Dept. A”和“Dept. B”那么可以指定一个别名给后者“[Dept. A:LDAP 服务器]”。 注意，如果提供的信息能识别唯一的基本项目，可以不必指定用户名。

3. 不同的用户名也可以被用于不同的类似基本项目之间，例如，“[LDAP 服务器:赵]”与“[LDAP 服务器:孙]”。

4. 最后，所有三字段可指定，如:“[Dept. A:LDAP 服务器:赵]”

显示

基本项目，即项目至少有一个别名“指向”它们，在树状目录视图显示为一个绿色三角形而不是绿色正方形。

别名项目在白色三角形图标处显示。


导出与导入纯文本文件格式

警告: 从一个 Password Safe 数据库导出敏感信息为一个文本文件存在严重的安全后果。 该操作将创建一个无保护的密码数据库副本。在不充分使用与其它作用后请适时删除该副本及擦除数据 (例如: 第三方 “粉碎” 文件公用程序)。导出的敏感数据事实上将绕开 Password Safe 程序的安全措施。

备注: 导出与导入文本文件功能从 V3.06 开始后被改变。该页面描述了当前格式。

导出文本将:

  • 文本文件以标题行作为开始
  • 使用一个分隔符代替 多行备注字段的 “换行符” 及呈现在标题字段的句号 (‘.’)； 默认为 ‘»’ [Alt+0187]，如果需要则可以被覆盖。

导入文本假定存在:

  • 文本文件以标题行作为开始。
  • 使用一个分隔符恢复 多行备注字段的 “换行符” 及呈现在标题字段的句号 (‘.’)； 默认为 ‘»’ [Alt+0187]，如果需要则可以被覆盖。

目前标题行完整数据导出包含下列标记分隔的默认字段:

  • 组/标题
  • 用户名
  • 密码
  • 网址
  • 自动导入
  • 创建时间
  • 修改密码时间
  • 最后访问时间
  • 密码失效日期
  • 记录修改时间
  • 历史密码
  • 备注

在导出数据时，可以使用“高级”功能排除这些标题行字段中的许多记录。 高级选项同样允许用户指定导出项目的一个子集，显示如下:

Advanced Text Export dialog box

在导入数据时，提供标题行必须包括“栏目标题”精确匹配上面的任何一个。如果存在“栏目标题”重复，在导入时只有最后一个数据被添加到项目；如果一个“栏目标题”不匹配上面的任何一个，栏目中的数据在导入时将被忽略。字段必须被字段分隔符分隔指定给导入文本对话框中的数据。

备注:
  • 需要导入所有数据到 Password Safe 里，标题与密码字段 必须 存在和既不可间隔也不可空缺，因为这里将添加一个新项目到现有数据库中。
  • 这里并没有与“栏目标题”相似的限制。Password Safe 将提供标题行正确添加规定数据到右边的字段中。

数据格式

栏目标题/字段

注释

组/标题

如呈现， 组被句号 (‘.’) 分隔。标题字段不能空格、空缺或包含分隔符。

用户名

密码

不能空格或空缺。

网址

自动导入

创建时间

查看下列备注 1

修改密码时间

查看下列备注 1

最后访问时间

查看下列备注 1

密码失效日期

查看下列备注 1

记录修改时间

查看下列备注 1

历史密码

查看下列备注 2

备注
  • 备注字段应加上双引号 (“这样”)。
  • 备注字段不应包含分隔符，因为导入后将被转移到一个新行。

备注:

1

时间字段可为下列 3 个格式之一:
  1. yyyy/mm/dd hh:mm:ss 例如: 2007/01/26 19:31:25
  2. ddd MMM dd hh:mm:ss yyyy 例如: 星期五 一月 26 19:31:25 2007
  3. yyyy-mm-ddThh:mm:ss 例如: 2007-01-26T19:31:25
  4. 0 撤销复位
  5. 即时 使用导入操作时间

位置:

  • yyyy 完整年份 值在 1970 至 2038之间。
  • mm 月份 例如: 01 表示一月，02 表示二月 等等。
  • dd 一个月中的第几日。
  • MMM 月份简易格式 例如: Jan 表示一月，Feb 表示二月 等等。
  • ddd 星期的简易格式 例如: Mon 表示星期一，Tue 表示星期二 等等。
  • hh 使用 24 小时计时。
  • mm 分
  • ss 秒
备注: 格式 "2" 是以 ANSI C 函数 "asctime"(将时间和日期以字符串格式表示) 导出与格式 "3" 遵照 ISO 8601 标准导出。

2

历史密码 的表示在导出项目记录为一个文本字段，包括一个标题然后为所需旧密码项目数量:

历史密码标题:

  • 1 十六进制数字 该项目保存历史密码状态 (0 = no; 1 = yes)
  • 2 十六进制数字 在该项目的最大项目编号
  • 2 十六进制数字 当前保存项目编号

每个历史密码项目:

  • 8 十六进制数字 当时的旧密码设置
  • 4 十六进制数字 旧密码长度
  • 字符串 旧密码


参数选择

PasswordSafe 参数选择

像许多应用程序一样， PasswordSafe 允许用户配置它的性能与外观为符合用户偏好和所需的最佳套件。 许多应用程序把如此的参数选择存储在 Windows “注册表”，似乎是一种约定成俗与方便的事情。 早期版本的 PasswordSafe 也用过注册表，但经过验证存在问题的原因如下:
1. 一些可配置的参数选择与安全是相关的并存储它们在一个开放的储存库中，如 Windows 注册表 也许能让黑客获得访问数据库的权利 (例如，假定黑客通过禁止数据库锁定一个禁止超时后， 用户总以为数据库被安全的锁定在运行之外，而黑客却因此能方便的访问它)。
2. 许多人使用的 PasswordSafe 是在 U 盘上的或相反共享同样的数据库跨越多个计算机， 如此共享配置数据在注册表是不切实际的。

PasswordSafe 有许多的参数选择，每个都具有一个合理的默认值。 当用户更改配置为一个非默认值时，新值便存储在 PasswordSafe 中。
PasswordSafe 定义参数选择以安全相关或非安全相关为目的。 前者保存在数据库，加密使用一样的密匙作为用户数据。
非安全相关的参数选择保存在一个配置文件 pwsafe.cfg 中。该文件是 XML 格式，具有每个主机与每个用户节点。 因此该文件可以共享在不同的用户与跨越不同的计算机之间。
默认情况下，pwsafe.cfg 保存在 pwsafe.exe 可执行程序相同目录下。 无论何种情况，PWS_PREFSDIR 环境变量的设置， pwsafe 都将使用这里存储配置文件。这对于写入 pwsafe.exe 安装目录位置权限约束是极有帮助的。

下列表格描述配置项，大部分可通过管理->选项对话框配置。

布尔值 (true/false) 参数选择

首选项 | 默认 | 存储位置 | 注释
alwaysontop | false | pwsafe.cfg | 主窗口总在上面
showpwdefault | false | 数据库 | 默认显示密码
showpwinlist | false | 数据库 | 列表视图显示密码
sortascending | true | 数据库 | 升序筛选
usedefuser | false | 数据库 | 使用默认用户
saveimmediately | true | 数据库 | 立即保存
pwuselowercase | true | 数据库 | 密码生成策略
pwuseuppercase | true | 数据库 | 密码生成策略
pwusedigits | true | 数据库 | 密码生成策略
pwusesymbols | false | 数据库 | 密码生成策略
pwusehexdigits | false | 数据库 | 密码生成策略
pweasyvision | false | 数据库 | 密码生成策略
dontaskquestion | false | pwsafe.cfg | 不询问问题
deletequestion | false | pwsafe.cfg | 删除时询问
DCShowsPassword | false | pwsafe.cfg | 文档显示密码
DontAskMinimizeClearYesNo | true | pwsafe.cfg | 最小化清除不询问 是/否
DatabaseClear | false | pwsafe.cfg | 数据库清除
DontAskSaveMinimize | false | pwsafe.cfg | 最小化时不询问保存
QuerySetDef | true | pwsafe.cfg | 默认查询设定
UseNewToolbar | true | pwsafe.cfg | 使用新式工具栏
UseSystemTray | true | pwsafe.cfg | 使用系统托盘
LockOnWindowLock | true | pwsafe.cfg | 锁定在最后界面
LockOnIdleTimeout | true | pwsafe.cfg | 空闲超时锁定
EscExits | true | pwsafe.cfg | 设 Esc 键退出
HotKeyEnabled | false | pwsafe.cfg | 启用热键
MRUOnFileMenu | true | pwsafe.cfg | 大部分最近用过的数据库
DisplayExpandedAddEditDlg | true | 数据库 | 默认 更多/缩减 细节
MaintainDateTimeStamps | false | 数据库 | 维护 日期/时间 印记
SavePasswordHistory | false | 数据库 | 保存历史密码
FindWraps | false | pwsafe.cfg | 查找换行
ShowNotesDefault | false | 数据库 | 默认显示备注内容
BackupBeforeEverySave | true | pwsafe.cfg | 每次保存之前备份
PreExpiryWarn | false | pwsafe.cfg | 密码失效提醒
ExplorerTypeTree | false | pwsafe.cfg | 在树状目录首位显示分组
ListViewGridLines | false | pwsafe.cfg | 在列表视图显示网格线
MinimizeOnAutotype | true | pwsafe.cfg | 自动导入时最小化

数值参数选择

首选项 | 默认 | 存储位置 | 最小 | 最大 | 注释
column1width | n/a | pwsafe.cfg | n/a | n/a | 栏目 1 宽度
column2width | n/a | pwsafe.cfg | n/a | n/a | 栏目 2 宽度
column3width | n/a | pwsafe.cfg | n/a | n/a | 栏目 3 宽度
column4width | n/a | pwsafe.cfg | n/a | n/a | 栏目 4 宽度
sortedcolumn | 0 | pwsafe.cfg | 0 | 15 | 筛选栏目
pwlendefault | 8 | 数据库 | 4 | 1024 | 默认密码长度
maxmruitems | 4 | pwsafe.cfg | 0 | 20 | 大部分最近用过的数据库
IdleTimeout | 5 | 数据库 | 1 | 120 | 空闲超时
DoubleClickAction | 双击复制密码 | pwsafe.cfg | n/a | n/a | 双击操作
HotKey | 无 | pwsafe.cfg | n/a | n/a | 热键
MaxREItems | 25 | pwsafe.cfg | 0 | 25 | 最近项目最大数量
TreeDisplayStatusAtOpen | 全部收缩 | 数据库 | n/a | n/a | 打开时树状目录状态
NumPWHistoryDefault | 3 | 数据库 | 0 | 255 | 保存多少历史密码
BackupSuffix | 0 | pwsafe.cfg | n/a | n/a | 备份后缀
BackupMaxIncremented | 1 | pwsafe.cfg | 1 | 999 | 最大备份增量
PreExpiryWarnDays | 1 | pwsafe.cfg | 1 | 30 | 涉及密码失效提醒的时间

文本参数选择

首选项 | 默认 | 存储位置 | 注释
currentbackup | <无> | pwsafe.cfg | 最后备份文件的路径与名称
currentfile | <无> | pwsafe.cfg | 当前 (也就是最后) 已打开的文件
lastview | 树状目录 | pwsafe.cfg | 最后视图选中: 树或列表视图
defusername | <无> | 数据库 | 默认用户名
treefont | <无> | pwsafe.cfg | 树状目录字体
BackupPrefixValue | <无> | pwsafe.cfg | 备份前缀值
BackupDir | <无> | pwsafe.cfg | 备份目录
AltBrowser | <无> | pwsafe.cfg | 更换浏览器
ListColumns | <无> | pwsafe.cfg | 非默认栏目排序
ColumnWidths | <无> | pwsafe.cfg | 非默认栏目宽度
DefaultAutotypeString | \u\t\p\t\n | 数据库 | 默认自动导入字串


运行命令

一个项目的“运行命令”字段可以包含一个在选择运行命令操作时运行的命令。 该命令也是可以在你的电脑开始->运行框输入的任何可执行的命令。

另外，Password Safe 能传递参数给命令，如：项目用户名称、密码等，参阅下面描述。 这些命令允许你对“程序”执行相当复杂的操作，如调用一个远程访问程序（PuTTY, 示例）并使它的项目相关的用户名和密码通行。

总而言之，“变量” 是代替在传递给计算机执行之前与它们相关的值。美元（'$'）标志是用来表示一个变量的。

  • 变量规定为“$名称”并 区分大小写。变量名总是以一个字母字符开始并且其余字符为字母数字。 变量名结束在遇上一个非字母数字字符（如一个空格）或者运行命令末尾中的任何一个。
    • 要使用一个变量直接跟随一个字母数字字符在运行命令里，必须把变量名包围在大括号里，例如：“${变量名}字串”。
    • 要使用一个“$”在字串中作为正常文字（不指示以下文字是一个变量名），避开它使用一个反斜杠符号（“\”）， 例如：“\$文字”变成“$文字”而不是当做一个变量名“文字”。
    • 要使用一根反斜杠在“$”之前作为一根反斜杠符，避开它同时使用另一根反斜杠线。例如：“\\$名称” 变成“\$名称”产生的文字和“$名称”被视为一个变量。 反斜杠符不必避开，除非先于“$”被指示为下列变量。
    • 一个变量可以跟随一个数值在方括号里，称为“索引值”。该索引值“n”可加上“+”或“-”。例如：[-2] 或 [2] 或 [+2]。 Password Safe 将把一个索引看作等于无意义的整个字段。

  • 下列变量是目前承认的:

    • 应用程序相关:
      • appdir 路径包含 Password Safe 应用程序。查看下面的备注 1 & 2 。

    • 当前数据库相关:
      • dbdir | 当前打开的数据库目录。查看下面的备注 1 & 2 。
fulldb | 完整路径，文件名和当前打开的数据库扩展名。查看下面的备注 2 。
dbname | 当前打开的数据库文件名。
dbextn | 当前打开的数据库扩展名。

    • 当前项目相关:
      • g 或 group | 组 （完全树目录结构返回到根目录组分隔圆点）。
G 或 GROUP | 仅包含该项目的组。
t 或 title | 标题
u 或 user | 用户名
p 或 password | 密码
a 或 autotype | 自动输入。查看下面的备注 5 。
url | 网址
n 或 n[0] | 完整的备注字段 (也可以: notes或notes[0])。查看下面的 3 。
n[i] 或 notes[i] | ith 从备注字段起始行计数。例如：i=1 表示第一行；i=2 意思为第二行 等。查看下面备注 4 。
n[-i] 或 notes[-i] | ith 从备注字段结束行计数。例如：i=1 表示最后一行；i=2 意思为倒数第二行 等。查看下面备注 4 。

      备注
      1 | 目录值（appdir 或 dbdir）没有一个结束符“\”，请记住如果你需要添加它在运行命令里。
      2 | 变量的内容（包括完整的目录和路径值）可能包含空白。您可能需要把你的运行命令包括在引号中才能正确执行。
      3 | 如果你的备注字段包含大于一行的文字，它将包含回车符(CR)或换行符(LF)。这些可能导致在运行 CR 和/或 LF 时将被当作“enter”的问题。
      4 | 任何后缀 CR 和/或 LF 将从备注字段被选中的单独行中删除。
      5 如果自动输入变量存在运行命令，一旦目标窗口被激活自动输入将被执行。变量与它的值如果存在， 将从被执行的字串里删除。该变量可出现在任何地方运行命令，作为它唯一指定 Password Safe 将出现在已执行的命令字串之后。 不像其它的变量，这是一个将会覆盖项目当前值的输入值。格式如下（在项目的示例“$autotype”可取代“$a”）:
      $a | 使用当前项目的值。
${a} | 使用当前项目的值（用于假如文字直接跟随 '$a' 变量）。
$a（值） | 使用自动输入字串规定在圆括号之间。
${a}（值） | 使用自动输入字串规定在圆括号之间。

      备注: 如有必要一定给你的字串添加引号标识。例如：如果你的数据库目录包含空格，要访问你打开的数据库名中的一个文本文件， 你应该操作如下（使用引号）:
      “$dbdir\\$dbname.txt”
      注意反斜杠被避开以便 '$dbname' 被承认为一个变量。

      在 Windows 中，环境变量的正常取代（指定为 %变量_名称%）被执行。 例如:“%windir%\notepad.exe”可能变成（随你的安装而定）“C:\Windows\notepad.exe”。 当前值的设置在你的环境里可视运行的“cmd.exe”和“设置”命令有没有任何参数结果而定。 任何未知的环境变量在运行命令中保持不变，例如：%xyz%\notepad.exe 依旧是 %xyz%\notepad.exe 如果变量“xyz”未设定。
      备注: Windows 环境变量不区分大小写。


快捷键

快捷键/加速键

以下是作为 PasswordSafe 相关的自定义快捷键性能限制详细资料。

这些组合键已经过102-键扩展的英国键盘上的测试。标准字符与拉丁字符应该都安装在任何其它键盘上。 一些组合键可能在这些键盘上存在差异，如：在英国键盘上“#”符号有它自己的键（具有加在西班牙语n字上的发音符号~）； 但在美国键盘上则是 3 字符（即 Shift+3）。 请仔细阅读此表并变换适合你的特殊键盘-你总能看到具体的实验某一组合键是如何工作的。

依你的键盘变换，某些键和 Alt 键已被保留。相对的 Alt 常被用于调用主菜单。按 Alt 键主菜单字母将出现下划线。 对于英文版软件，Alt 键总是存在，如： Alt+F (File), Alt+E (Edit), Alt+V (View), Alt+M (Manage) 以及 Alt+H (Help)。 对于非英文版软件，请参考这些下划线字母在你的主菜单上将如何为你预定的。 例如：在德文版 "File" 菜单变成 "Datei" 因此 Alt+D 将预留取代英文版通常的 Alt+F； 中文版则中文菜单名称后加括号的英文大写字母，该字母完全继承于英文版相同字母。如：文件(F)、编辑(E)等。

Enter（回车键） 也是作为预留给快捷方式的，其值被预设到 管理->选项->快捷方式属性页。因此，不能分配给该键其它功能。 请注意“展开/收缩组”功能在树目录视图模式是通过选择组和按住回车键实现的。 虽然，该键可能已被改变到其它任何有效的快捷方式， 作为使用中的回车键功能，在树目录视图状态下其原来功能仍然有效。 基于此原因，该功能不能通过快捷方式属性页改变。

Escape（换码键） 是预留作为关闭查找工具栏或最小化 Password Safe 到系统托盘的快捷键。 它也相当于在任何对话框上的取消按钮。

按照设计，快捷方式值作为在只读模式查看项目与在读写模式状态下编辑项目是一样的。它们不能单独设置。 同样，“删除项目”、“删除组”和“重命名项目”以及“重命名组”也都一样。 这些显示在快捷方式属性页上的内容仅作为各自“删除”和“重命名”之用。

部分键是预留给 Windows 系统的-如：Ctrl+Alt+Delete; Tab; Shift+Tab; Alt+Tab;Alt+Shift+Tab 等。

非标准键不支持（如：只有在汉字键盘上独有的键）。

PasswordSafe 快捷方式设置不承认不同之间的 Alt, Ctrl 和 Shift 键，如已设置为键盘左边的键时，右边相同的键则不被承认有效。 这也许会让一些组合键在某些键盘上无法使用。例如：欧洲符号在英国 102 扩展键盘右 Alt 键(Alt Gr)和 4 键。 不管怎样，按该组合键都将导致 Ctrl+Alt+4 的快捷方式结果。 因为，这是微软系统热键进程引起，而不是 Password Safe 所限制的。

备注: 设置非标准键可能使这些特定的快捷方式无法使用。如果你在使用其它电脑由于键盘没有这些键， 建议您只从下列这些表中选择组合键。

下面表格中，查看列标题意思:

标题 | 指 压
K | 仅此键
A+K | 组合 Alt 键
C+K | 组合 Ctrl 键
S+K | 组合 Shift 键
A+S+K | 组合 Alt 和 Shift 键
C+S+K | 组合 Ctrl 和 Shift 键
A+C+K | 组合 Alt 和 Ctrl 键
A+C+S+K | 组合 Alt、Ctrl 和 Shift 键

键名称 | K | A+K | C+K | S+K | A+S+K | C+S+K | A+C+K | A+C+S+K
Backspace | Y | N | Y | Y | N | Y | Y | Y
Tab | N | N | Y | N | N | Y | Y | Y
Enter | R (1) | N | Y | N | N | Y | Y | Y
Escape | N | N | N | N | N | N | N | N
Space | Y | N | Y | Y | N | Y | Y | Y
Page Up | Y | Y | N | Y | Y | N | N | N
Page Down | Y | Y | N | Y | Y | N | N | N
End | Y | Y | Y | Y | Y | Y | Y | Y
Home | Y | Y | Y | Y | Y | Y | Y | Y
← | Y | Y | Y | Y | Y | Y | Y | Y
↑ | Y | Y | Y | Y | Y | Y | Y | Y
→ | Y | Y | Y | Y | Y | Y | Y | Y
↓ | Y | Y | Y | Y | Y | Y | Y | Y
Print Screen | N | N | N | N | N | N | N | N
Insert | Y | Y | Y | Y | Y | Y | Y | Y
Delete | Y | N | Y | Y | N | Y | N | Y
0-9 | Y | Y | Y | Y | Y | Y | Y | Y
A-Z | Y | Y | R (2) | Y | Y | Y | Y | Y
Num pad 0-9 | Y | Y | Y | N | Y | N | Y | N
Num pad * | Y | Y | Y | Y | Y | Y | Y | Y
Num pad + | Y | Y | Y | Y | Y | Y | Y | Y
Num pad - | Y | Y | Y | Y | Y | Y | Y | Y
Num pad . | Y | Y | Y | N | N | N | N | N
Num pad / | Y | Y | Y | Y | Y | Y | Y | Y
F1 | R (3) | Y | Y | Y | Y | Y | Y | Y
F2 | Y | Y | Y | Y | Y | Y | Y | Y
F3 | Y | Y | Y | Y | Y | Y | Y | Y
F4 | Y | R (2) | Y | Y | Y | Y | Y | Y
F5 | Y | Y | Y | Y | Y | Y | Y | Y
F6 | Y | Y | Y | Y | Y | Y | Y | Y
F7 | Y | Y | Y | Y | Y | Y | Y | Y
F8 | Y | Y | Y | Y | Y | Y | Y | Y
F9 | Y | Y | Y | Y | Y | Y | Y | Y
F10 | Y | Y | Y | Y | Y | Y | Y | Y
F11 | Y | Y | Y | Y | Y | Y | Y | Y
F12 | Y | Y | Y | Y | Y | Y | Y | Y
Num Lock | Y | Y | N | Y | N | Y | Y | Y
Scroll Lock | Y | Y | Y | Y | Y | Y | Y | Y
; : (4) | Y | Y | Y | Y | Y | Y | Y | Y
+ = | Y | Y | Y | Y | Y | Y | Y | Y
, < | Y | Y | Y | Y | Y | Y | Y | Y
- _ | Y | Y | Y | Y | Y | Y | Y | Y
. > | Y | Y | Y | Y | Y | Y | Y | Y
/ ? (4) | Y | Y | Y | Y | Y | Y | Y | Y
# ~ (4) | Y | Y | Y | Y | Y | Y | Y | Y
[ { (4) | Y | Y | Y | Y | Y | Y | Y | Y
\ | (4) | Y | Y | Y | Y | Y | Y | Y | Y
] } (4) | Y | Y | Y | Y | Y | Y | Y | Y
' @ (4) | Y | Y | Y | Y | Y | Y | Y | Y
` ¬ (4) | Y | Y | Y | Y | Y | Y | Y | Y

备注:

  1. 由于回车键是用于设定快捷方式值的，所以它不能分配给任何功能。

  2. Ctrl+Q 和 Alt+F4 组合键保留给 Password Safe 应用程序退出时使用。

  3. F1 键是专门保留给帮助文档。

  4. 以上表格中“Y” 表示可以组合；“N” 表示不可组合；“R” 表示 Windows 系统预保留键。

  5. 以上这些可能取决于你的键盘。


程序功劳

感谢 Bruce Schneier 创造 Twofish 算法与释放 Password Safe 给公众以及感谢 SourceForge.net 托管该项目并提供开源社区支持。
Password Safe 版本 3.06 及后来使用的 TinyXML 分析应用程序配置文件，其 TinyXML 代码利用根据下列条款 zlib license。
Password Safe 版本 3.12 和后来使用的生成可发音密码算法由 Tom Van Vleck, Morrie Gasser 和 Dan Edwards 所创造。

跟随下列链接到达 SourceForge 网站有关 Password Safe 项目的若干页面:

  • Password Safe 首页: 关于 Password Safe 信息与新闻，同时也公告项目状态及新版本的发布。
  • 程序开发组: 只是民间一些帮助开发和保持 Password Safe 继续运行的开发者。
  • Password Safe 论坛: 提供问题、支持与疑难解答的交流平台。
  • Password Safe 新闻: RSS 馈送该项目的可用信息。
  • Password Safe 少量(大致每月一个消息或稍多些)免费宣传公告与用户邮件发送清单页面。

简体中文编译: 小镇医生
电子邮箱: Freedoctor@qq.com